네트워크/CCIE R&Sv5.0 2015.02.16 17:58

CCIE R&S V5 TS 문제 풀이 / TSHOOT 문제 풀이 / CCIE Routing and Switching Version 5.0 TS 문제 풀이

 

- 익숙해지기전까진, 부분 토폴로지를 보면서 연습하도록 합니다.

- 어떤 명령어를 추가 및 삭제/수정해야지만, 완벽한 결과값이 나오는지를 숙지하도록 연습해야 합니다.

 

 

1. VLAN/DHCP

 

 1) DHCP

 

   - R7&R8 DHCP 서버 ----- PC110 DHCP 클라이언트

   - R7&R8 DHCP 서버 설정 내용

   -  IP 주소, 서브넷 마스크, 기본 게이트웨이, 클라이언트-ID MAC 주소

 

 2) VLAN & Trunk

 

  - SW1&SW2 VLAN 정보 및 Access 설정 내용 확인
  - Trunk Allowed 확인(vlan 12)

 

 3) SVI 인터페이스

 

  - VLAN 12

 

 4) Port-Security 설정이 있다면, PC MAC 주소 확인

 


2. PPP

 

 1) R12(PPP 서버)

 

 - R17에게 할당할 DHCP 서버 설정 내용 확인
 - R17 인증을 위한 'username/password' 정보 확인
 - PPP 인터페이스(Serial 인터페이스)에 DHCP Pool 적용 확인

 

 2) R17(PPP Client)

 

 - PPP 인터페이스(Serial 인터페이스)에 PPP 로그인 'username/password' 설정 확인
 - IPCP를 통한 기본 경로 설정 확인(ppp ipcp route default)

 

 3) R17 Serial 인터페이스 shutdown -> no shutdown

 


3. OSPF 로드 분산

 

 1) OSPF 메트릭 조정 관련 설정 확인

 

 - 'max-metric router-lsa' 삭제
 - 'ip ospf cost' 삭제

 

 2) OSPF 네이버 성립 확인

 

 - passive-interface 삭제

 - router-id 중복 체크 -> 수정한 이후 -> 'clear ip ospf process' 실행

 - Area 주소 확인

 

 3) OSPF 수동 요약 삭제

 

  - area 1 range x.x.x.x x.x.x.x <- 삭제
 
 4) OSPF 네트워크 타입 확인

 

  - ip ospf network point-to-point 삭제

 

 5) R1에서 로드 분산 명령어 확인

 

  - maximum-path 1 <- 삭제

 

 6) Distribute-list & ACL 설정

 

  - 라우팅 업데이트 차단 부분 확인 및 ACL 설정 삭제

 


4. EIGRP 로드 분산

 

 1) bandwidth, delay 명령어 삭제

 

 2) EIGRP 네이버 성립 확인

 

   - K-상수 미스 매치로 인한 EIGRP 네이버 성립 불가능 현상 해결
   - 'passive-interface' 설정 확인

 

 3) offset-list 설정에 R4 Lo0 정보 제외

 

 4) distribute-list 설정에 R4 Lo0 정보 제외

 


5. BGP 라우팅 정책

 

 1) Local-Preference 설정

 

    - prefix-list 설정
    - route-map 설정

 

 2) MED 설정

 

    - prefix-list 설정
    - route-map 설정

 

 3) R12에서 BGP 로드 분산 명령어 확인

 

    - maximum-path 2

 

 4) R3&R5 route-reflector-client 설정

 

router bgp 12345
 address-family ipv4
 neighbor 123.4.4.4 route-reflector-client
 neighbor 123.6.6.6 route-reflector-client

 


6. IPv6

 

 1) 인터페이스에 설정된 IPv6 주소 확인

 

 2) R25-----R22-----R26 eBGP 네이버 설정 확인
          IPv4      IPv6

 

 3) R25, R26 내부 인터페이스 정보 BGP 라우팅 업데이트 설정 확인 


 4) R25-R22-R26 BGP 네이버 확인

 

   - show ip bgp ipv6 unicast summary

 

 5) R25-R22-R26 BGP 업데이트 확인

 

   - show ip bgp ipv6 unicast

 

 6) R25, R22에서 IPv6 PBR(넥스트-홉 변경) 설정 확인

 


7. DMVPN

 

1) R15 'Connected' 재분배 삭제(플랩핑 발생 해결)

 

router eigrp 200
 redistribute connected


2) DMVPN 관련 설정 확인

 

 - Hub(R15) Split-horizon 해지 확인(no ip split-horizon eigrp 200)
 - Hub(R15) & Spoke(R17,R18,R19) NHRP 인증 패스워드 확인
 - Spoke(R17, R18, R19) NHRP 정적 맵핑 설정 확인(Hub 라우터쪽 IP 주소 설정 미스 컨피그)
 - Spoke(R17, R18, R19) NHRP 설정 중 'ip nhrp nhs' 확인(Hub 라우터쪽 IP 주소 설정 미스 컨피그)
 - Spoke(R17, R18, R19)에서 ACL inbound 설정이 있다면, ESP 허용 해줘야 함

 

3) EIGRP 200 설정

 

 - Spoke(R17, R18, R19)에서 'eigrp stub receive-only' 삭제


3) Traceroute 결과

 

  - Hub(R15) 라우터 경유 O

 

       Hub(R15) : no ip next-hop-self eigrp 200 명령어 사용 X
       Hub(R15) : ip nhrp redirect 명령어 사용 X

 

  - Hub(R15) 라우터 경유 X

 

       Hub(R15) : no ip next-hop-self eigrp 200 명령어 사용 O

 

  또는

 

 Hub(R15) : ip nhrp redirect 명령어 사용 O

 

4) Spoke(R17, R18, R19) 'eigrp stub receive-only' 삭제


5) 문제 해결 이후, Tunnel 0 인터페이스 shutdown -> no shutdown 실시

 


8. MPLS

 

1) PC104#traceroute 172.16.2.18

 

 어떤 라우터까지 패켓이 가는지 확인

 

2) R9->SW3, R10->SW4 OSPF 기본 경로 라우팅 업데이트 확인

 

SW3#show ip route
SW4#show ip route

 

@ R9, R10

router ospf x
 default-information originate always <- 확인

 

3) VRF acme 구간 R7->R3, R8->R4 BGP 기본 경로 라우팅 업데이트 확인

 

R7,R8#show run

router bgp 61000
 address-family ipv4
 neighbor 123.61.1.x default-originate


4) LSR 라우터 확인 및 PE, P 라우터 확인

 

R3(PE)       R4(PE)
│               │
│               │  
R1(P)-----------------R2(P)
│               │
│               │
R5(PE)      R6(PE)


5) VRF(RD/RT)

 

 - 라우팅 업데이트가 가능한 RT 값 설정 유무 확인
 - 그림 참조



9. NAT/DHCP/DNS

 

1) NAS 라우터 VTY 설정 확인

 

line vty 0 4
 password cisco
 login
 transport input telnet


2) DHCP

 

R23 DHCP 서버 - NAS DHCP 클라이언트인 경우
 
 - R23 DHCP 서버 설정 확인
 - NAS 클라이언트-ID MAC 주소 확인
 - R23 E0/1 - NAS에게 할당할 IP 주소 설정 확인(IP 중복됨)

 

3) DNS

 

 상위 DNS 서버 : 8.8.8.8(google)
 하위 DNS 서버 : R23

 

 - DNS 서버 실행

 

Router(config)#ip dns server

 

 - DNS 서버 지정

 

Router(config)#ip name-server x.x.x.x

 

 - DNS 요청 실시

 

Router(config)#ip domain-lookup


4) NAT

 

 R23에서 NAT 설정
 
 - 정적 NAT : R21#telnet 202.123.1.1  <---- NAS IP 주소(domain : nas.home.net)
 
   포트 번호 확인 및 정적 NAT 설정 유무
  
 - 동적 NAT : R24#ping 194.1.3.1 <- R26 루프백 IP 주소(domain : www.cciecloud.net)
 
   ACL 확인 및 동적 NAT 설정 유무

 - R21과 R23 연결된 구간 라우팅 업데이트 설정 확인

 - 그림 참조

 


10. DMVPN + NAT

 

1) R24, R7 DMVPN 설정 확인

 

 - IKE 1단계

 

crypto isakmp policy x
 encryption aes
 hash sha
 group 2 <------- 확인
 authentication pre-share
!
crypto isakmp key cisco address x.x.x.x <--- 확인(0.0.0.0으로 수정 권장)

 

 - IKE 2단계

 

crypto ipsec transform-set CISCO esp-aes esp-sha-hmac
 mode tunnel 또는 transport

 

2) R24, R7 OSPF 네이버 성립 확인

 

 - OSPF 네이버 성립 조건

 

 Hello/Dead Interval 동일
 MTU 사이즈 동일 <------------- 확인
 같은 네트워크은 동일한 Area로 구성
 라우터 아이디 중복 X
 Stub Area 구간 라우터는 Stub 설정 실시


3) R23 NAT 설정

 

@ R23

 

crypto ipsec nat-transparency udp-encapsulation <- 기본값이라 안보임

 

   - NAT-T 패켓 정적 NAT 확인(UDP 포트 번호 출발지/목적지 4500번)

 

ip nat inside source static udp 192.168.1.1 4500 202.123.1.1 4500

 

   - IKE 패켓 정적 NAT 확인(UDP 포트 번호 출발지/목적지 500번)

 

ip nat inside source static udp 192.168.1.1 500 202.123.1.1 500


4) 문제 풀고 이후, R24&R7 tunnel 0

 

int tunnel 0
 shutdown
 no shutdown

'네트워크 > CCIE R&Sv5.0' 카테고리의 다른 글

mpls ip propagate-ttl 명령어  (0) 2015.02.16
IPSec VPN 기본 내용  (0) 2015.02.16
CCIE R&Sv5 CFG 시험 연습하는 방법  (0) 2015.02.16
CCIE R&S V5 TS 문제 풀이 / TSHOOT 문제 풀이  (0) 2015.02.16
CCIE DIAGNOSTICS 문제  (0) 2015.02.16
Posted by 김정우 강사(카카오톡 : kim10322)


Q